package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)((\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})$`)
var str = `256.255.255.122`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}