$re = '/^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)((\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3})$/';
$str = '256.255.255.122';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);