import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^<@([A-Z0-9]+)>)*.+[\\s]([0-9]+)";
final String string = "<@U0BUPU9QQ> 49\n"
+ "50\n"
+ "<@U0BUPU9QQ>\n"
+ "<@U0BUPU9QQ> noget 49 noget andet tekst 5 40\n"
+ "<@U0BUPU9QQ> noget andet tekst 5 40\n"
+ "<@U0BUPU9QQ|mn> has joined the channel";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}