re = /(?:^<@([A-Z0-9]+)>)*.+[\s]([0-9]+)/m
str = '<@U0BUPU9QQ> 49
50
<@U0BUPU9QQ>
<@U0BUPU9QQ> noget 49 noget andet tekst 5 40
<@U0BUPU9QQ> noget andet tekst 5 40
<@U0BUPU9QQ|mn> has joined the channel'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end