import re
regex = re.compile(r"(\[(img|\w{4,})\][\s\S]*?\[\/\2\])(\n?)|([\s\S]+?)(\n?)(?=$|\[(?:img|\w{4,})\])", flags=re.IGNORECASE)
test_str = ("Cum haec taliaque sollicitas eius aures everberarent expositas semper eius modi\n"
"rumoribus et patentes.\n"
"[image]https://foo.com/fighters.png[/image]\n"
"Denique Antiochensis ordinis vertices sub uno elogio iussit occidi ideo efferatus,\n"
"quod ei celebrari vilitatem intempestivam urgenti, cum inpenderet inopia\n"
"[image]https://foo.com/fighters1.png[/image]\n"
"[image]https://foo.com/fighters2.png[/image]\n"
"Utque proeliorum periti rectores [i]primo catervas[/i] densas opponunt et fortes,\n"
"deinde leves armaturas, post iaculatores ultimasque subsidiales acies, si fors\n"
"adegerit")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")