# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/|\\{1,2}/\\\\/gm;t' <<< "/test\\dso\dsa"