$re = '~/|\\\\{1,2}~m';
$str = '/test\\\\dso\\dsa';
$subst = "\\\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;