package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?&]PS3_ALVRO(?:&|$)`)
var str = `https://archive.org/download/PS3_ALVRO_PART_6
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}