$re = '/[?&]PS3_ALVRO(?:&|$)/m';
$str = 'https://archive.org/download/PS3_ALVRO_PART_6
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);