using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w-)*@-(?:\w-)*\.(?:-\w)*";
string input = @"a-b-c-@-d-e-.-e-f-g
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}