$re = '/(?:\w-)*@-(?:\w-)*\.(?:-\w)*/';
$str = 'a-b-c-@-d-e-.-e-f-g
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);