using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([123])((?!\1)\d)(?!\2|\1)\d";
string input = @"123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}