$re = '/([123])((?!\1)\d)(?!\2|\1)\d/m';
$str = '123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);