#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mix)((?:[ -$&(-[\]-~]|([%'\\])\2)*(%(\d+\$)?[-+\s0#]?(\d+|\*)?(\.\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!(?:[ -$&(-[\]-~]|([%'\\])\7)*(?:%(?:\d+\$)?[-+\s0#]?(?:\d+|\*)?(?:\.\d+)?[bt]?[diuoxXfeEgGcs]+)+)(?:[ -$&(-[\]-~]|([%'\\])\8)*)?)" & @CRLF & _
""
Local $sString = "Color %s, we are looking for %%02droids %% number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"I wanted to also add the ability to capture "any printable text characters besides %, ' and \, unless these characters appear exactly twice". This needs to be captured both before the initial % and after the conversion character." & @CRLF & _
"" & @CRLF & _
"any printable character: [ -~]" & @CRLF & _
"besides %, ' and \: (?![\\%'])" & @CRLF & _
"these characters appear exactly twice: ( §§§§ |'{2}|\\{2}|%{2}) (§ = placeholder)" & @CRLF & _
"I am having a problem with the "unless", that is, getting the negative look-ahead to discard single occurrences but allow double occurrences of the specified characters." & @CRLF & _
"" & @CRLF & _
"Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u." & @CRLF & _
"| | | | | | |"
Local $sSubst = "IMAGE REMOVED FROM CHROME\r\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)