const regex = /((?:[ -$&(-[\]-~]|([%'\\])\2)*(%(\d+\$)?[-+\s0#]?(\d+|\*)?(\.\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!(?:[ -$&(-[\]-~]|([%'\\])\7)*(?:%(?:\d+\$)?[-+\s0#]?(?:\d+|\*)?(?:\.\d+)?[bt]?[diuoxXfeEgGcs]+)+)(?:[ -$&(-[\]-~]|([%'\\])\8)*)?)
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[ -$&(-[\\]-~]|([%\'\\\\])\\2)*(%(\\d+\\$)?[-+\\s0#]?(\\d+|\\*)?(\\.\\d+)?[bt]?[diuoxXfeEgGcs]+)+(?:(?!(?:[ -$&(-[\\]-~]|([%\'\\\\])\\7)*(?:%(?:\\d+\\$)?[-+\\s0#]?(?:\\d+|\\*)?(?:\\.\\d+)?[bt]?[diuoxXfeEgGcs]+)+)(?:[ -$&(-[\\]-~]|([%\'\\\\])\\8)*)?)
', 'gmi')
const str = `Color %s, we are looking for %%02droids %% number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u.
I wanted to also add the ability to capture "any printable text characters besides %, ' and \\, unless these characters appear exactly twice". This needs to be captured both before the initial % and after the conversion character.
any printable character: [ -~]
besides %, ' and \\: (?![\\\\%'])
these characters appear exactly twice: ( §§§§ |'{2}|\\\\{2}|%{2}) (§ = placeholder)
I am having a problem with the "unless", that is, getting the negative look-ahead to discard single occurrences but allow double occurrences of the specified characters.
Color %s, number1 %d, number2 %05d, hex %#x, float %5.2f, unsigned value %u.
| | | | | | |`;
const subst = `IMAGE REMOVED FROM CHROME\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);