import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Project\\(\\\"\\{[\\w-]+\\}\\\"\\)\\s*=\\s*\\\"(\\w+)\\\"[,\\s]+\\\"([^\\\"]+\\.vcxproj)\\\"[,\\s]+\\\"(\\{[\\w-]+\\})\\\"";
final String string = "Project(\"{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}\") = \"ConsoleApplication1\", \"ConsoleApplication1\\ConsoleApplication1.vcxproj\", \"{3136B732-9CB7-4B25-8CEA-3DCCD0634A6C}\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}