$re = '/Project\(\"\{[\w-]+\}\"\)\s*=\s*\"(\w+)\"[,\s]+\"([^\"]+\.vcxproj)\"[,\s]+\"(\{[\w-]+\})\"/';
$str = 'Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "ConsoleApplication1", "ConsoleApplication1\\ConsoleApplication1.vcxproj", "{3136B732-9CB7-4B25-8CEA-3DCCD0634A6C}"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);