package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:foo)\b|\b(?:foo){2,}\b`)
var str = `foo foofoo
foo foo fooo
-foo foo foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}