$re = '/\b(?:foo)\b|\b(?:foo){2,}\b/';
$str = 'foo foofoo
foo foo fooo
-foo foo foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);