using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"o cara(.*)no carro";
string input = @"""o cara da pamonha bateu com o carro no carro de fulano""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}