import re
regex = re.compile(r"o cara(.*)no carro")
test_str = "\"o cara da pamonha bateu com o carro no carro de fulano\""
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")