import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\[)|(?!\\A)\\G)[^][]*(\\[[^]]+\\])";
final String string = "[[1,2,3],[3,5,3],[9,8,9]] aoeu [5,6,9] aoeu [[4,5,5]] [[1,2,3],[3,5,3],3]\n"
+ "[[1,2,3],4,[3,5,3],3]\n"
+ "[1,2,3,[3,5,3],3]\n"
+ "[1,2]";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}