$re = '~(?:(?:\[)|(?!\A)\G)[^][]*(\[[^]]+\])~x';
$str = '[[1,2,3],[3,5,3],[9,8,9]] aoeu [5,6,9] aoeu [[4,5,5]] [[1,2,3],[3,5,3],3]
[[1,2,3],4,[3,5,3],3]
[1,2,3,[3,5,3],3]
[1,2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);