using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=_).+(?=\.)";
string input = @"Filename_01-23-AB.exe
Filename2_01-23-AB.exe
Filename01-23-AB.exe
Filename_01-23-AB_asdfasdf.ex.exe";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}