$re = '/(?=_).+(?=\.)/mi';
$str = 'Filename_01-23-AB.exe
Filename2_01-23-AB.exe
Filename01-23-AB.exe
Filename_01-23-AB_asdfasdf.ex.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);