package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(\d+\)`)
var str = `(10) Joystick Switch - Contains control switches (Figure 50)
Two (2) heavy lifting straps
(22) blah
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}