$re = '/^.*(.).*\1.*$(*SKIP)(*F)|^[abcd]+$/m';
$str = 'abcd
abc
aaa
ab
a
abb
abcb
dbca
dbda
bdba
cbad
gfgf
hjkl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);