re = /^.*(.).*\1.*$(*SKIP)(*F)|^[abcd]+$/m
str = 'abcd
abc
aaa
ab
a
abb
abcb
dbca
dbda
bdba
cbad
gfgf
hjkl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end