#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[description\]:(?:.+\n?)*"
Local $sString = " [type]: mail" & @CRLF & _
" [category]: Values" & @CRLF & _
" [service]: testing" & @CRLF & _
" [description]: Testing out automapping of email" & @CRLF & _
" Line break Testing out automapping of email" & @CRLF & _
" Line break Testing out automapping of email"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")