re = /\[description\]:(?:.+\n?)*/
str = ' [type]: mail
[category]: Values
[service]: testing
[description]: Testing out automapping of email
Line break Testing out automapping of email
Line break Testing out automapping of email'
# Print the match result
str.match(re) do |match|
puts match.to_s
end