#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=(?:.*?[a-z]){2})[a-z\d](?!.*?[._]{2})[\w.]{1,23}[a-z\d]$"
Local $sString = "1rockit.man" & @CRLF & _
"q3w" & @CRLF & _
"e4.45r.d.2" & @CRLF & _
"sp_am" & @CRLF & _
"" & @CRLF & _
".ret." & @CRLF & _
"123" & @CRLF & _
"12a" & @CRLF & _
"ret..wer" & @CRLF & _
"super_.duper" & @CRLF & _
"_petrat" & @CRLF & _
"petrat_" & @CRLF & _
"" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaaaaaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")