$re = '/^(?=(?:.*?[a-z]){2})[a-z\d](?!.*?[._]{2})[\w.]{1,23}[a-z\d]$/mi';
$str = '1rockit.man
q3w
e4.45r.d.2
sp_am
.ret.
123
12a
ret..wer
super_.duper
_petrat
petrat_
aaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);