$re = '/^((0[1-9])|(1[0-2]))(([0-2][1-9])|(3[0-1]))((19\d\d)|(2\d\d\d))$/';
$str = '12311902';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);