import re
regex = re.compile(r"^((0[1-9])|(1[0-2]))(([0-2][1-9])|(3[0-1]))((19\d\d)|(2\d\d\d))$")
test_str = "12311902"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")