const regex = /(.+)@(.+),(.+),(.+)z\/(.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)@(.+),(.+),(.+)z\\\/(.+)', '')
const str = `https://www.google.com/maps/place/Hyatt+Fisherman's+Wharf/@37.805954,-122.416108,17z/data=!3m1!4b1!4m2!3m1!1s0x808580e4799a55a5:0x6d7309ae49b784bb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}