$re = '/(.+)@(.+),(.+),(.+)z\/(.+)/';
$str = 'https://www.google.com/maps/place/Hyatt+Fisherman\'s+Wharf/@37.805954,-122.416108,17z/data=!3m1!4b1!4m2!3m1!1s0x808580e4799a55a5:0x6d7309ae49b784bb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);