#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^?\n]*\?.*=\d{3,4}(?:&|$)"
Local $sString = "http://www.website.com/our-resources/news/?p=1" & @CRLF & _
"http://www.website.com/example/voice-of-the-customer/news/?p=12" & @CRLF & _
"http://www.website.com/our-resources/news/?p=123" & @CRLF & _
"http://www.website.com/example/?p=4321" & @CRLF & _
"http://www.website.com/example/products/touchchat/news/?p=12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")