# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^?\n]*\?.*=\d{3,4}(?:&|$)"
test_str = ("http://www.website.com/our-resources/news/?p=1\n"
"http://www.website.com/example/voice-of-the-customer/news/?p=12\n"
"http://www.website.com/our-resources/news/?p=123\n"
"http://www.website.com/example/?p=4321\n"
"http://www.website.com/example/products/touchchat/news/?p=12345")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.