const regex = /^.*(uol.com.br\/)(\d+)-*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(uol.com.br\\\/)(\\d+)-*', 'gm')
const str = `http://thumb.mais.uol.com.br/15516553-medium.jpg?ver=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}