$re = '/^.*(uol.com.br\/)(\d+)-*/m';
$str = 'http://thumb.mais.uol.com.br/15516553-medium.jpg?ver=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);