package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+\s*(\S+)\s*(\S+)\s*(\S+).*$`)
var str = `I have 1000 dollars
I want my pet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}