use strict;
my $str = 'Cooooool
happyyyyyy';
my $regex = qr/((.)\2{2})\2+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";