$re = '/((.)\2{2})\2+/m';
$str = 'Cooooool
happyyyyyy';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;