package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<SITE_NAME>^[A-Z 0-9]{3})`)
var str = `KUL6LJBJ62YD
BLR6LC7BLNJR
HRI6M5G6KKPH
KUL6LJ3N0F6J
HRI6LBJKRHHR
HRI6LB65G6NF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}