import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<SITE_NAME>^[A-Z 0-9]{3})";
final String string = "KUL6LJBJ62YD\n"
+ "BLR6LC7BLNJR\n"
+ "HRI6M5G6KKPH\n"
+ "KUL6LJ3N0F6J\n"
+ "HRI6LBJKRHHR\n"
+ "HRI6LB65G6NF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}