using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@[a-z]+,)([\t ]*([a-z]+)[\t ]*(?=\[[a-z]+\])|[\t ]+)";
string substitution = @"$1$3";
string input = @"@foo, bar
@foo, bar [john]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}