re = /(@[a-z]+,)([\t ]*([a-z]+)[\t ]*(?=\[[a-z]+\])|[\t ]+)/mi
str = '@foo, bar
@foo, bar [john]'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result