const regex = /(\d*\.?\d+)(?:\([^()]*\)|[a-zA-Z]*\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*\\.?\\d+)(?:\\([^()]*\\)|[a-zA-Z]*\\b)', 'gm')
const str = `0
1
0.1
.1
1g
0.1g
.1g
1(g/100ml)
.1(g/ml)
1abc
0.1, 1, 0.1cc, 100(g/1000L)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}