$re = '/(\d*\.?\d+)(?:\([^()]*\)|[a-zA-Z]*\b)/m';
$str = '0
1
0.1
.1
1g
0.1g
.1g
1(g/100ml)
.1(g/ml)
1abc
0.1, 1, 0.1cc, 100(g/1000L)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);