using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/([a-zA-Z0-9]*)\/([a-zA-Z0-9-.\_-]*)\/([a-zA-Z0-9-.!:;,^$&|*?@%\_\/-]*)";
string input = @"/pods/lscis.gov/request/green-card";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}